Forum Settings
       
Reply To Thread

ITS UP!!!Follow

#52 Aug 24 2013 at 3:07 AM Rating: Decent
*
53 posts
My launcher on PS3 wont even display the login screen now. :p
#53 Aug 24 2013 at 3:07 AM Rating: Decent
Just JP Servers so far. Some kind of bias system XD
#54 Aug 24 2013 at 3:07 AM Rating: Decent
24 posts
Catwho wrote:
Still can't get a connection to the NA/EU servers. Smiley: tinfoilhat


Same here, still staring at "Obtaining the World list..." under Group NA/EU =P
#55 Aug 24 2013 at 3:07 AM Rating: Good
*
180 posts
Well I knew it wasn't going to be a smooth ride and I'm glad I'm not alone on it.
#56 Aug 24 2013 at 3:07 AM Rating: Decent
24 posts
Did it take a while for Ultros server to show up?
#57 Aug 24 2013 at 3:07 AM Rating: Default
SE, Y U NO PREPARED FOR THIS ****!?
#58 Aug 24 2013 at 3:08 AM Rating: Good
*
126 posts
Black launcher. Ugh. Wellp...
#59 Aug 24 2013 at 3:08 AM Rating: Decent
I see a repeat of Vanguard: Saga of Hero's happening LOL, nah but really let's cut them some slack they're about to get hammered by us early bird players.
#60 Aug 24 2013 at 3:08 AM Rating: Decent
login servers crapped out already?
#61 Aug 24 2013 at 3:08 AM Rating: Decent
*
180 posts
anyone know if there is a way to skip that opening movie when installing on new computers?
#62 Aug 24 2013 at 3:09 AM Rating: Decent
"This world is currently full" Players in que 81
#63 Aug 24 2013 at 3:09 AM Rating: Decent
*
210 posts
It you early bird players causing all the problems! Go to bed and let the right time zone players play!
#64 Aug 24 2013 at 3:09 AM Rating: Decent
*
51 posts
It keeps saying unable to update NA/EU world list. I'm worried to exit the client and try again.
#65 Aug 24 2013 at 3:09 AM Rating: Good
**
310 posts
my world list appeared after i restarted the client
#66 Aug 24 2013 at 3:09 AM Rating: Decent
EXPLODE!!!!!!
#67 Aug 24 2013 at 3:09 AM Rating: Excellent
They had until last Monday morning to get cut slack. This is the real deal. No sympathy from me. Smiley: disappointed
#68 Aug 24 2013 at 3:09 AM Rating: Excellent
*
53 posts
I'm in!!!! And stable! Happy EA!!!
#69 Aug 24 2013 at 3:09 AM Rating: Good
This is to be expected. Launch days are rough.
#70 Aug 24 2013 at 3:09 AM Rating: Excellent
*
220 posts
Finally I'm in and playing.....all right I'm burnt out on FFXIV whens the next game coming out :P
#71 Aug 24 2013 at 3:10 AM Rating: Decent
I'm in. Just keep trying, though i'm sure no one is giving up.
#72 Aug 24 2013 at 3:10 AM Rating: Decent
Joys of missing the start ;) ill be on after 5 when its calmed down.
#73 Aug 24 2013 at 3:10 AM Rating: Good
*
230 posts
Login screen stays black then I get a system error.. lol.. I dont know why I always try to stay up for these things, something ALWAYS happeneds
#74 Aug 24 2013 at 3:10 AM Rating: Good
*
246 posts
Launcher black only, then a language error message.
#75 Aug 24 2013 at 3:10 AM Rating: Excellent
**
311 posts
If you look at http://arrstatus.com even the lobby is down. The JP servers aren't even up.

SE should have been better prepared.
#76 Aug 24 2013 at 3:11 AM Rating: Decent
38 posts
Aaaaaaand, it's down. :\ Only saw JP servers.

Edited, Aug 24th 2013 5:11am by iAmEcchi
Reply To Thread

Colors Smileys Quote OriginalQuote Checked Help

 

Recent Visitors: 20 All times are in CST
Anonymous Guests (20)